Jump to content
Sign in to follow this  
samaron

Tower konvertert Amiga 1200 - begitt meg ut på ukjent farvann...

Recommended Posts

samaron    52

Fikk nettopp et PowerPC kort til amigaen! Blizzard PPC med 256MB RAM, 68060 overclocket fra 50 til 66 MHz og PPC fra 240 til 330 MHz. Denne har også ultra wide SCSI controller. :) Har også fått laget en plate med logo for å fylle noe av det ledige med. Limte den fast til en ødelagt CD-ROM. Plastikken har ganske lik farge som resten, så fornøyd med resultatet. Lasergravert. :)

 

20150213_173217_zpsde598a3a.jpg

20150213_174509_zps2f44e032.jpg

20150212_151451_zps31ad99aa.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites
Olav    64

Det er strengt tatt ikke nødvendig med så mye kjøling på et skjermkort som er allerede designet til å kjøre med passiv kjøling..

EDIT: Hvor mye betalte du for Blizzard PPC-en?

Edited by Olav

Share this post


Link to post
Share on other sites
samaron    52

Er overkill med kjølingen på skjermkortet. Veldig klar over det, men hadde ganske mange vifter liggende så tenkte "hvorfor ikke?" :P Tror ikke du vil vite hvor mye Blizzard PPCen kostet, ble mye mer enn det folk flest ville vurdert. Denne er også oppgradert, som legger på en del på prisen. Fikk også med SCSI hard disk, original eske osv som plusser på litt også. Ville ha det beste som er å oppdrive. Målet er som sagt den "ultimate" amiga. :) Kunne kjøpt en Amiga One eller noe slikt, men vil ha klassisk hardware og operativsystem. Det som gjør prosjektet gøy er jo oppgraderingsmulighetene som eksisterer.

 

Har også slitt litt med PPCen. Fikk bare ikke denne til å fungere. Installasjonen med Blizzard 1260en startet rett opp når jeg plugget i kortet. Når jeg installerte WarpUP (driverene for PPC prosessoren) så hang maskinen seg etter reboot. Etter en hel helg med prøving og feiling så fant jeg ut av det. Kontaktet polakken jeg kjøpte kortet av og ble rådet å kjøre en "barebone test". Mens jeg plukket av Mediatoren og alt det så gikk det opp for meg at jeg hadde helt glemt å koble til ekstra 5 volt spenning i kretsen. Hadde også målt spenningen på feil sted, hadde helt glemt av at jeg kunne måle direkte på kjølevifta til prosessoren. Målte da 3,056 volt, som er 2 volt for lite... Ikke rart maskinen henger seg når PPC prosessoren blir aktivert. Satser på et par ekstra ledninger løser problemet.

 

Jeg målte spenningen på en av molex kontaktene. Selvsagt målte jeg 5 volt stabilt siden det var direkte til strømforsyningen. Burde egentlig ha visst dette, men mistet hodet litt i feilsøkingsprosessen. Er spenningstap i kretsen, så vil jo gi reell verdi hvis jeg måler direkte på problempunktet. Ganske flaut jeg ikke tenkte så langt...

Edited by samaron

Share this post


Link to post
Share on other sites
Olav    64

Er lett å overse små ting i blant.

Genial setup, er misunnelig! Har en A4000D med Picasso IV 4MB RTG og 68060/50MHz (modifisert A3640, så FastRAM-en har en del waitstates, så den er ikke like rask som en 060 acc med egen RAM).

Amiga har sjarm!

Share this post


Link to post
Share on other sites
samaron    52

Må bare finne litt ledning jeg kan bruke, så får se neste uke om jeg får ordet opp i problemet. :) Må koble meg inn på strømkontakten til diskettstasjonen på hovedkortet. Må få skaffet meg et nytt Compact Flash kort på Clas Ohlson også, har slettet og skrevet så mange ganger på mitt nå at det har begynt å få lesefeil. :P

 

Amiga 4000 er flotte maskiner. Vurderte en slik, men valget falt på Amiga 1200. En ordentlig "hacker-maskin", noe en A4000 ikke ville blitt siden den allerede er laget med card slots osv. Vil tro mitt setup kjører fra det meste, men er et sant helvete å få det til å fungere. Sjarmen med high-end Amiga. :) Lært mye av å holde på. Føler det er motbakkene som gir best læring, selv om det til tider er ekstremt slitsomt.

 

Når jeg får ordnet opp i spenningsproblemet så håper jeg det blir fart i sakene. Satser på å få til Quake II, burde kjøre ganske smooth med en 330 MHz PowerPC og Voodoo3 grafikkort. :)

 

Har også bestilt meg en ny vifte som jeg skal montere over prosessorene. Vil ikke klistre på noe kjøleribber siden prosessorene ikke er så varme i utgangspunktet. Er varme, men kan fint holde fingeren på uten å brenne meg.

Share this post


Link to post
Share on other sites
samaron    52

Har nå loddet på ekstra strømtilførsel til hovedkortet. Loddet på ledninger til jord og 5 volt på floppy drive kontakten på hovedkortet. Strømmen henter jeg fra en av molex kontaktene fra strømforsyningen. Hvor mye dette hjalp vet jeg ikke, har fortsatt en stabil og god 4,9 volt i systemet. Gikk opp for meg at jeg foretok målingene på PPC kortet med vifta tilkoblet, noe jeg ikke burde. Koblet denne av i noen sekunder, og joda, får 4,9 volt der også. Så ser ut som problemet med spenningen egentlig ikke er et problem likevel. Kortet oppfører seg som før fortsatt.

 

Skjønner ikke hvor vanskelig det burde være å sette opp dette kortet. Har seriøse problemer nå med Internett og forum som hjelp, tørr ikke tenke på hvor problematisk dette må ha vært på 90-tallet når dette var nytt. Hold på hele helgen uten å være ett steg nermere egentlig.

Edited by samaron

Share this post


Link to post
Share on other sites
Olav    64

Kjipern. 1D.1 er det beste hovedkortet med tanke på kompatibilitet og bugs (mangel på dem, rettere sagt). Om du har et ESCOM A1200-hovedkort (de leverte 1D.4 og 2B) så er antakeligvis fiksen allerede gjort.

Share this post


Link to post
Share on other sites
samaron    52

Er et revisjon 2B hovedkort jeg har nå. Lest flere tråder hvor den revisjonen har skapt problemer. Stoler heller ikke helt på hovedkortet. Det skjedde et uhell hvor det kom noe metall borti RGB video kontakten. Maskinen skrudde seg selv av momentant. Startet fint opp igjen etter å ha skrudd av og på strømmen. Kan ikke si det er noe forskjell, virker tilsynelatende helt i orden. Stoler likevel ikke helt på hovedkortet lenger, så bør nok bytte det uansett.

Share this post


Link to post
Share on other sites
samaron    52

Fikk tak i et revisjon 1D1 hovedkort! Betalte en liten formue for dette, tydeligvis sjeldne og ettertraktet. Gleden viste seg å være kortvarig... Koblet den opp på benken for å teste den, tenkte å videresende den til england for å bytte kondensatorene. Når jeg skrudde på maskinen så kom det røyk umiddelbart. Skrudde av igjen etter kanskje 3 sekunder. Strømkabelen til diskettstasjonen brant opp, bokstavelig talt. Sjekket hovedkortet og fant noen ganske dårlige loddinger på strømkontakten, samt noen dårlige rundt videokretsen. I følge eBay selgeren skulle hovedkortet fungere, bra jeg testet det før jeg videresendte det igjen... Kontaktet en bruker på AmiBay forumet som jeg har sendt hovedkortet til. Han er en "tech wiz" på dette og var optimistisk på å reparere den. Han skulle renske opp og fikse loddepunktene, og eventuelt reparere ødelagte baner på kretskortet. Minst én av kondensatorene lekker elektrolyttvæske. Han skal også teste og bytte kondensatorer som er defekte. Så er et lite lys i tunellen likevel. :)

 

20150409_173730_zpsyed6ke44.jpg

20150409_173738_zpshnmuhkge.jpg

20150409_173803_zps0b3p8ju8.jpg

20150409_173911_zpsf79sxsh6.jpg

20150409_171710_zpswebkpm1h.jpg

Share this post


Link to post
Share on other sites
samaron    52

Har fått svar fra tyskeren som skal fikse hovedkortet. Er ikke helt bra ser det ut til. Jeg siterer:

 

So the A1200 PCB has arrived and there are several problems that need to be resolved.

First off, the capacitors: This half disolved track is (was) the positive terminal of C409.
The capacitor has obviously been leaking for quite a while and has damaged quite a few tracks
around the power regulation, which is probably what's causing most of the problems.

Prob3_zpsc2dtvb4a.jpg

 

The capacitors haven't just caused local damage, there's damage to the expansion connector too, which is a long way from any capacitor.

Prob2_zpswhqc0y5l.jpg

 

And this mess is the 5V pin to floppy drive. What worries me here is that the damage seems to come from within the PCB, so the acid may have travelled through the internal layers. Hopefully not, but I'll find out as soon as I have removed all the offending parts.

Prob1_zpsfdkvbzdg.jpg

 

Sorry the news isn't better Samaron. I'll see what I can do.

Share this post


Link to post
Share on other sites
samaron    52

Endelig noen gode nyheter! Han som overhaler hovedkortet mitt har brukt litt tid, men endelig kom han i mål! Nesten alle kondensatorene gikk i oppløsning når han tok dem av, alle var syreskadet. Den ene kondensatoren hadde lekket så mye også at lederene på kretskortet var spist vekk. Nå har han fikset alle de dårlige loddepunktene og byttet alle kondensatorene. Nå ser det ut til å fungere som det skal. :)

 

Jeg siterer:

 

So I finally found enough time to finish this repair (got a massive amount of repairs in at the moment). First the good news, everything is back working perfect. In the first picture you can see some of the damage the leaked capacitor did.

 

Recap1_zpsgbul88nw.jpg

Recap2_zpsr5v18dpy.jpg

 

To install the new capacitor I just scratched the surface off the tracks left and right and could install the new capacitor with just a slightly new angle, but it doesn't get in the way of anything by doing this, it just looks a bit crooked. Then I replaced all the others and gave it an initial "bare board" test. Nothing like a freshly recapped A1200. :)

 

Recap3_zpsbzv4v85s.jpg

Recap4_zpstdbz5o6w.jpg

 

Everything was fine, time to do a load test. For this I connect an internal CF Card, the floppy drive, keyboard and a Blizzard 1220/4 to test the expansion port. Then I measure the ripple on the 12V and 5V rails. Still all fine. I do a boot from CF, boot from floppy and check the Blizzard with Sysinfo. I've also tested the PCMCIA with a RAMCard and the other ports manually. Last up I did a "burn-in" by leaving the game Banshee running over night. It was still running very happily the next morning, so I'd consider this a stable system at this stage :) Time to pack it up and send it back.

 

Recap5_zpsa4klwykc.jpg

Recap6_zps7sire6tc.jpg

Share this post


Link to post
Share on other sites
samaron    52

Ja, han var høyst anbefalt kar over på AmiBay forumet. Ikke mye han tok for jobben heller, 25 euro + frakt. Bildet er også klart og fint, så tror dette blir det beste hovedkortet jeg har eid til nå. Alle andre hovedkort har hatt dårlig bilde, selv med RGB. Fikk skyggeeffekt på bildet og litt støy. Noe dette hovedkortet ikke lider av. :) Siden det er revisjon 1D1 så håper jeg det ikke blir noen flere problemer med PowerPC prosessorkortet. Skal hvertfall være et kompatibelt hovedkort. :)

 

Kjøpte meg også en 300 watt AT strømforsyning på eBay. Følte det ville bli feil med ATX, vil ha den gode gamle "av/på bryteren" som AT har. Blir også mer riktig med tanke på at OSet ikke støtter soft shutdown. Merket er Athena, usikker på hvor bra det er. Strømforsyningen i seg selv veier ikke mer enn 1,2kg, så tror ikke det er noe high-end kvalitet på den ut i fra vekten.

 

Blir ny oppdattering så snart jeg får hovedkortet tilbake og montert det!

Edited by samaron

Share this post


Link to post
Share on other sites
tassel    0

Beklager å dra opp en gammel tråd, men det er et morsomt prosjekt du har gående her.

Hvem er det du bruker til recapping på Amibay?

Jeg har fått recappa 2 x A1200 og 1 x A4000 kort hos en som holder til i Larvik. han har virkelig gjort en glimrende jobb og satt på kvalitets komponenter + rengjøringen han har gjort får kortene til å se splitter nye ut.

 

Jeg har også endel prosjekter som jeg har holdt på med en stund, men tiden strekker ikke alltid til. Er vel forsåvidt ferdig med en A500 Black Ed. som jeg er ganske fornøyd med. 

Håper at det er flere som får interesse av å bruke Amiga'en fremover her i Norge.

 

WVOyDyD.jpg

flDy5h8.jpg

Edited by tassel

Share this post


Link to post
Share on other sites
samaron    52

Tøff 500 du har der! Hvor fikk du knappene fra? En CDTV?

 

Brukte en kar som heter bryce på amibay. Holder til i tyskland. Han gjorde en fantastisk jobb. Hovedkortet mitt hadde fått en del skader som følge av kondensatorene, så måtte litt lapping til for å få det opp å gå. Tok vel 30 euro for jobben.

 

Beklager at jeg ikke har vært så flink til å oppdattere tråden her med prosjektet mitt. Det er enda ikke i havn, men har den siste tiden ikke gjort så mye med det.

 

Hovedproblemet har vært at hver gang jeg prøver å installere noe, så fikk jeg plutselig "write error" og systemet frøs. Dette ville gjenta seg, så kom aldri noe særlig langt. Ville gjerne satt opp systemet i emulatoren først, men kan ikke installere FastATA og Mediator (med tilhørende kort) der.

 

Etter en del tenking så fant jeg ut at kabelen til SD kortet var 60cm lang, som er visstnok litt i det lengste laget. Kanskje derfor jeg fikk skrivefeil hele tiden? Byttet ut denne med en harddisk og ting begynte å gå på skinner igjen! Fikk kopiert over et ferskt OS fra emulatoren, installert drivere og software og null problemer. Eller... lyden fra sound blasteren hadde forvrengning, som var litt rart. Testet dette i en PC og fungerte feilfritt der. Er nok noe drivertrøbbel eller lignende. Skulle egentlig se mer på dette denne helgen, men natt til fredag klarte min fulle far å søle en liter med øl over maskinen.... Usikker på hvordan jeg skal få vasket denne ordenlig, stinker fortsatt ganske forferdelig. Ganske surt om en datamaskin til rundt 20.000kr gikk i dass med hans idioti.

 

Her er hvertfall et bilde med HDD koblet til i plassen for CF kort, før den ble druknet:

 

IMG_20150815_180914_zpstww9sust.jpg

 

Som dere ser så fungerer RTG glimrende ved 1280x1024. Voodoo3 er skjermkortet jeg bruker. Følte den gikk litt varm, så monterte aktiv kjøling på den tidligere.

 

IMG_20150815_180929_zpsjw586wvw.jpg

Share this post


Link to post
Share on other sites
tassel    0

Jepp, Jeg hadde 2 x CDTV tastatur liggende og har lånt fra det ene tastaturet i mangel på selve CDTV'n som jeg ikke har klart og skaffe meg enda. 
Det er mye frem og tilbake med disse Amiga'ene, men når man får alt opp, så er det jo bare tut og kjør :)

 

Jeg har aldri hatt noe PPC kort til Amiga, har alltid holdt meg til classic Amiga (Eller; Jeg har et par 060 kort for å titte på demoer)

 

Håper ikke øl'et ødelegger for mye, det ville jo være synd å se denne maskinen ende sine dager :/

 

Gøy og følge med på prosjektet ditt. Jeg har noen Amiga prosjekter jeg skal igang med når vinteren kommer, men det involverer ikke disse grisedyre PPC og Cybervision/Picasso kortene ;)

Share this post


Link to post
Share on other sites
samaron    52

Jeg ville ha den "ultimate" Amigaen. En 4000 ville jo være det enkleste å jobbe med siden den allerede er laget for å kunne ha ekstra kort osv. Er på en måte litt kulere med en 1200 hvor alt dette er tredjeparts oppgraderinger som maskinen ikke var tiltenkt å ha. :)

 

Jeg skaffet først et Blizzard 1260 kort, trodde disse PPC kortene var "enten eller" greier. Når jeg var klar over at prosessorene kjører sammen, eller etter behov, så ville jeg heller ha dette. Er selv tilhenger av klassisk OS, så det nyeste jeg kjører er OS 3.9 som fortsatt er 68k. PPC delen er mer tiltenkt å kunne kjøre 3D spill som Quake og Wipeout. Er også en Doom port som er mye bedre på PPC. Er laget et fåtall demoer som krever 3D RTG og PPC, men tror disse er basert på Permedia2 chipsettet, så vil nok ikke fungere på Voodoo3 som er 3Dfx/glide.

 

Poenget med denne maskinen er egentlig demoer og bruke den til andre krevende ting, bare fordi det er mulig. Kommer til å legge inn alle de klassiske spillene, men blir også mye demoer, MP3, 3D spill, kanskje film også om jeg får spillerene til å fungere. Demoscenen er veldig interessant. Har vært heldig å komme i kontakt med en kar som drev med demoer og cracking på 90-tallet. Veldig interessant og lærerikt, men stort sett PC det går i. Jeg har selv vokst opp med PC, så Amiga er veldig annerledes og krevende.

 

Angående tilstanden på maskinen, så er den positiv. Har ikke startet den opp igjen enda, men har vasket bort mer eller mindre alt ølet. Det meste av elektronikken ble spart, kunne ikke se noen åpenbare "drukninger" eller flekker av øl. Er ganske sterk lukt og består stort sett bare av sukker, så er lett å se de skinnende flekkene om det er noe. Prosessorkortet fikk den værste støyten, men heldigvis minimalt. Har plukket av kjøleblokken til PPC prosessoren og vasker bort flekkene med q-tips og isopropanol. Satser på jeg får tid til å skru den sammen i løpet av uken. :)

 

Hvis alt overlevde, så håper jeg den snart blir satt opp ordentlig og blir stappet med alt mulig tenkelig av programvare, media og spill. :)

Share this post


Link to post
Share on other sites
4pLaY    3

Er litt Amiga folk i området enda, hender jeg har en Amiga kveld i ny å ne her hos meg på Lura i Sandnes. Ta gjerne kontakt om du vil komme i kontakt med andre lokale.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×